Bug Tracker

Opened 7 years ago

Closed 6 years ago

#6420 closed bug (invalid)

change event originating from vanilla JS doesn't propagate to jQuery bound handler in iE

Reported by: thetoolman Owned by:
Priority: low Milestone:
Component: event Version: 1.4.2
Keywords: ie6 change Cc:
Blocked by: Blocking:

Description

Change events bound to inputs don't receive events originating from vanilla javascript fireEvent/dispatchEvent trigger. iE only;

Attachments (1)

eventEg.html (1.2 KB) - added by thetoolman 7 years ago.
Example of problem

Download all attachments as: .zip

Change History (9)

comment:1 Changed 7 years ago by thetoolman

Here is my test case and fix; ensure you try it in iE !

http://github.com/thetoolman/jquery/commit/a228013a706999df8dd3f70508c4f1b4298b2c21

Changed 7 years ago by thetoolman

Example of problem

comment:3 Changed 6 years ago by john

  • Milestone changed from 1.4.2 to 1.4.3
  • Priority set to undecided

Unfortunately the patch as described there won't have the desired effect - it'll cause many more change events to fire (when we don't want them to). I'm not sure if this is something that we're going to focus on fixing right away. I'm keeping it in mind, though.

comment:4 Changed 6 years ago by snover

  • Status changed from new to open

comment:5 Changed 6 years ago by snover

#7292 is a duplicate of this ticket.

comment:6 Changed 6 years ago by snover

  • Milestone 1.4.3 deleted

Resetting milestone to future.

comment:7 Changed 6 years ago by addyosmani

  • Priority changed from undecided to low

comment:8 Changed 6 years ago by dmethvin

  • Resolution set to invalid
  • Status changed from open to closed

This code won't work properly because it checks for attachEvent first. In IE9 and Opera both attachEvent and addEventListener exist; jQuery uses addEventListener for that case.

Note: See TracTickets for help on using tickets.