Bug Tracker

Opened 10 years ago

Closed 10 years ago

#6404 closed bug (worksforme)

.ajaxStop not firing on IE8 -> jquery 1.4.2

Reported by: lukemacneil Owned by:
Priority: Milestone: 1.4.3
Component: unfiled Version: 1.4.2
Keywords: ajaxstop ie8 Cc:
Blocked by: Blocking:

Description

After upgrading from jq 1.4.1 to 1.4.2 I noticed my loader stopped hiding after ajax requests, but only in IE8.

$(document).ajaxStart(function() {

$('#loading').toggle();

}).ajaxStop(function() {

$('#loading').toggle();

});

This works in FF 3.6.3, and .ajaxStart fires in IE8, but the div is never hidden upon completion.

I can't find any errors or warnings that point to the reason why.

Change History (2)

comment:1 Changed 10 years ago by dmethvin

I am not sure why the problem is occurring but that is not the recommended way to use .ajaxStart/Stop. Instead try this:

$("#loading")

.ajaxStart(function(){ $(this).show(); } .ajaxStop (function(){ $(this).hide(); }

http://api.jquery.com/ajaxStart/

comment:2 Changed 10 years ago by dmethvin

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.