Bug Tracker

Opened 10 years ago

Closed 9 years ago

#6387 closed bug (invalid)

jQuery 1.4.1 append/get returns 304 error in Firefox and Opera

Reported by: awdewolfe Owned by:
Priority: Milestone: 1.4.1
Component: ajax Version: 1.4.1
Keywords: Cc:
Blocked by: Blocking:

Description

I have the following code in the header of a page:

<script type="text/javascript"> Include standard download options menu

$.get('/lisird/scripts/download_options.html', function(data) {

$('#download_options').append($(data));

});

</script>

which loads <select id="filetype"><option value="csv" selected="selected">Text (.csv)</option><option value="la">LASP ASCII</option><option value="zip">Zipped CSV (.zip)</option></select>

into <span id="download_options"></span>

When using jQuery 1.4.1, in Safari and Chrome, the content (a simple form selector) is loaded into the page with no problem. In Firefox and Opera, the content is not appended at all, and Firebug returns a 304 error. Reverting to 1.3.2 eliminates the problem. Thanks for looking into this.

Change History (3)

comment:1 Changed 10 years ago by miketaylr

Have you tested this with jQuery 1.4.2, which is the most current release?

comment:2 Changed 9 years ago by dmethvin

Component: unfiledajax

Please check with 1.4.2 to see if the problem is still there; if so reopen with a complete test case.

comment:3 Changed 9 years ago by dmethvin

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.