Bug Tracker

Opened 10 years ago

Closed 9 years ago

#6375 closed bug (invalid)

All Tabs Displaying On Page Load.

Reported by: kennlucas Owned by:
Priority: Milestone: 1.4.3
Component: unfiled Version: 1.4.2
Keywords: Tabs Cc:
Blocked by: Blocking:

Description

I don't know why it is happening. Unfortunately right now I have to start over as things have gotten bad. I'll try to post an example here soon.

Basically, the tabs work fantastic. Love 'em!

However, when the page loads, ALL of the tabs are shown for a second then they collapse to looking as they should. I can't have my users see all of those tabs at once even for a second. It looks broken.

So... I had to have missed something when putting the tabs into my design. Again, I will try to post a "working" example soon... but for now, someone else must have run into this... yes?

Anyone?

Change History (3)

comment:1 Changed 10 years ago by kennlucas

OK... I KNOW this is the FOUC problem. I figured that part out.

But there is nothing that seems to work to correct it. And it is in all browsers. Not just IE.

So I'm heading back to square one with clean code. We'll see what happens from there.

comment:2 Changed 10 years ago by busstation16

This is by design, it allows people without javascript to see the content of your tabs.

If you really need to hide them, and don't care about people without javascript (or that have javascript turned off) you should be able to set the style of the tabs to "display: none" to hide them.

comment:3 Changed 9 years ago by dmethvin

Resolution: invalid
Status: newclosed

Not a jQuery core bug.

Note: See TracTickets for help on using tickets.