Bug Tracker

Opened 10 years ago

Closed 9 years ago

#6350 closed bug (duplicate)

Live change event works improperly for file inputs in IE8/7

Reported by: em286 Owned by:
Priority: undecided Milestone: 1.4.3
Component: event Version: 1.4.2
Keywords: IE live change file Cc:
Blocked by: Blocking:

Description

Assume we have the following code:

<input type="file" id="works" /> <input type="file" id="dsntwork" />

<script type="text/javascript"> <![CDATA[ $('#works').change(function(){alert("works")}); $('#dsntwork').live('change', function(){alert("works")}); ]]> </script>

When you pick a file for '#works' element you see the alerted text immediately. But when you pick the file for '#dsntwork' element you won't see any alerts untill you blur the element.

Change History (2)

comment:1 Changed 9 years ago by safeldm

I'm having the same issue although with an input select, if i use .change it works if i use .live('change',... it doesn't. moving the cursor off the select does not cause it to fire. Issue occurs in IE 8.

comment:2 Changed 9 years ago by snover

Priority: undecided
Resolution: duplicate
Status: newclosed

Duplicate of #5997.

Note: See TracTickets for help on using tickets.