Bug Tracker

Opened 10 years ago

Closed 10 years ago

#6348 closed bug (invalid)

:visited selector causes NS_ERROR_XPC_JS_THREW_STRING in Flock 2.5.6 (and presumably Firefox 3.0)

Reported by: tonydewan Owned by:
Priority: Milestone:
Component: selector Version: 1.4.2
Keywords: visited, NS_ERROR_XPC_JS_THREW_STRING Cc:
Blocked by: Blocking:

Description

The following snippet:

$('<span class="viewed">viewed</span>').insertBefore('section.pile li a:visited');

causes the following error in Flock 2.5.6, with jQuery 1.4.2 on OSX 10.6:

[Exception... "'Syntax error, unrecognized expression: Syntax error, unrecognized expression: visited' when calling method: [nsIDOMEventListener::handleEvent]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "<unknown>" data: no]

The error does not appear when using jQuery 1.3.x

I assume that the bug is also present in Firefox 3.0, but cannot replicate.

Change History (1)

comment:1 Changed 10 years ago by dmethvin

Resolution: invalid
Status: newclosed

The code snippet there isn't a complete test case, but since you mentioned it couldn't be reproduced in Firefox I'm going to say it's a Flock problem and not a jQuery one. Does Flock provide a place where you can report bugs?

Note: See TracTickets for help on using tickets.