Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#6311 closed bug (duplicate)

Problem with table row show / hide on firefox3.6

Reported by: fernando Owned by:
Priority: undecided Milestone: 1.4.3
Component: misc Version: 1.4.2
Keywords: Problem with table row show/hide on firefox3.6 Cc:
Blocked by: Blocking:

Description

Hello

We have a table with some lines are hide. The user has the option, trough a link, show them. It was working until the last Firefox upgrade. We are using the show effect to display the hide rows.

On the Firefox 3.6, after call the show method ($(".cls_receita").show()), the css attribute "display" is setted as "block". In all of other browser, this property is setted as "table-row".

When the property is setted as "block" all line (<tr>) is display on a unique column. That can be seen on the attached files, one of them on the Firefox 3.6 and another on the Firefox 3.5.8.

Thank you.

Attachments (2)

firefox_3_6.JPG (114.5 KB) - added by fernando 10 years ago.
Problem happening on Firefox 3.6
firefox_3_5_8.JPG (120.7 KB) - added by fernando 10 years ago.
The same screen working on the Firefox 3.5.8

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by fernando

Attachment: firefox_3_6.JPG added

Problem happening on Firefox 3.6

Changed 10 years ago by fernando

Attachment: firefox_3_5_8.JPG added

The same screen working on the Firefox 3.5.8

comment:1 Changed 10 years ago by milesslow

I had this issue in Firefox 3.6, jquery 1.4.2, on a span element within a td element.

If I call $('<span></span>').hide().show(), the span tag has the attribute style="display: block;". However, if I set an in-line display style like $('<span></span>').css('display','inline').hide().show(), it behaves correctly according to the API description.

comment:2 Changed 10 years ago by seasoup

Need a reduced test case... I tried the following in FF 3.6.3 and it worked fine, viewing selection source revealed an inline table-row display value.

<html> <head>

<script src="http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js" type="text/javascript"></script>

<script>

$(function () {

$('#something tr').hide().show();

}); </script> </head> <body>

<table id="something">

<tbody>

<tr><td>foo</td></tr>

<tr><td>foo</td></tr>

<tr><td>foo</td></tr>

</tbody>

</table>

</body>

</html>

comment:3 Changed 10 years ago by thephatmann

The problem occurs when a row is cloned, hidden, appended to a parent, and then shown. Code below.

<html>
  <head>
    <script src="http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js" type="text/javascript"></script>
    
    <script type="text/javascript">
      $(function () {
        row = $('#something tr')
        row.clone().hide().appendTo(row.parent()).show();
      }); 
    </script>
  </head>
  <body>
    <table id="something">
      <tbody>
        <tr>
          <td>
            foo
          </td>
        </tr>
        <tr>
          <td>
            foo
          </td>
        </tr>
        <tr>
          <td>
            foo
          </td>
        </tr>
      </tbody>
    </table>
  </body>
</html>

comment:4 Changed 9 years ago by snover

Priority: undecided
Resolution: duplicate
Status: newclosed

Duplicate of #2185.

comment:5 Changed 9 years ago by anonymous

html part

<tr id="show2_2" style="display:none;">

<td bgcolor="#e6e6ff">content</td>

</tr>

function{

document.getElementById('show5_1').style.display = 'table-row';

}

comment:6 Changed 9 years ago by anonymous

sorry the function will be

function{

document.getElementById('show2_2').style.display = 'table-row';

}

Note: See TracTickets for help on using tickets.