Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#6310 closed bug (duplicate)

onchange function might be executed twice in IE8

Reported by: mlangc Owned by:
Priority: undecided Milestone: 1.4.2
Component: event Version: 1.4.2
Keywords: Cc:
Blocked by: Blocking:

Description

Registering two change event handlers on the same element, one with jQuery.change() and another with element.onchange leads to the event handler that has been assigned to onchange to be executed twice. A simple example that illustrates this is attached.

Attachments (1)

jQueryOnChange.zip (24.8 KB) - added by mlangc 10 years ago.
Simple testcase

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by mlangc

Attachment: jQueryOnChange.zip added

Simple testcase

comment:1 Changed 9 years ago by brightertools

I get a similar problem when hard-wiring an onchange event on a select list and binding a 'change' event. the hard-wired event gets called twice in IE.

more info here: http://stackoverflow.com/questions/2888800/html-select-list-why-would-onchange-be-called-twice

comment:2 Changed 9 years ago by snover

Priority: undecided
Resolution: duplicate
Status: newclosed

Duplicate of #6593.

Note: See TracTickets for help on using tickets.