Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#6299 closed bug (duplicate)

jQuery 1.4.2 breaks AJAX success/failure behaviour

Reported by: damian.biollo Owned by:
Priority: undecided Milestone: 1.4.3
Component: ajax Version: 1.4.2
Keywords: Cc:
Blocked by: Blocking:

Description

There is a small change to the behaviour of httpSuccess() which breaks the behaviour of AJAX in Firefox.

The breakage is in the scenario when a user clicks a link while an AJAX request is being processed. In Firefox, clicking a link to navigate will immediately cancel all outstanding HTTP requests. (Check Firebug Console to see the behaviour).

In previous versions of jQuery, this would result in a "failure" - the failure ajax handler would be called.

In 1.4.2 this results in the "success" handler being called, which seems quite wrong.

The bug is due to adding a condition of "or xhr.status == 0" to the httpSuccess function.

Change History (4)

comment:1 Changed 10 years ago by guest

Similarly, xhr.status == 0 when connection to the server fails so the success callback runs.

comment:2 Changed 9 years ago by dmethvin

Component: unfiledajax

comment:3 Changed 9 years ago by snover

This is a duplicate of bug #6060.

comment:4 Changed 9 years ago by addyosmani

Priority: undecided
Resolution: duplicate
Status: newclosed

This is one of the bugs that was successfully addressed in #6060. As a fix for it will likely be included in 1.4.3, I am closing this ticket and assigning it duplicate status.

Note: See TracTickets for help on using tickets.