Bug Tracker

Opened 10 years ago

Closed 10 years ago

#6290 closed bug (invalid)

Inconsistent $.inArray behavior

Reported by: timmolendijk Owned by:
Priority: Milestone: 1.4.3
Component: misc Version: 1.4.2
Keywords: inArray Cc:
Blocked by: Blocking:

Description

Firefox (3.6 for OS X), Chrome (5 for OS X), Safari (4): $.inArray(undefined, []) === -1

Internet Explorer (7 & 8): $.inArray(undefined, []) === null

Change History (3)

comment:1 Changed 10 years ago by timmolendijk

I just found out that $.inArray(<anything>, []) === null in IE7&8

comment:2 Changed 10 years ago by timmolendijk

And then it turned out the behavior is caused by some external crap. Not sure yet what exactly. But I think this issue can be closed.

comment:3 Changed 10 years ago by dmethvin

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.