Bug Tracker

Opened 10 years ago

Closed 9 years ago

#6288 closed bug (wontfix)

Animate focus bug

Reported by: nahmias.dror Owned by:
Priority: undecided Milestone:
Component: manipulation Version: 1.4.2
Keywords: animate textarea Cc:
Blocked by: Blocking:

Description

when animating a textarea in its onfocus event the focus is lost. This happens in Chrome (dev, 5.0.342.3) and mobile safari (iPhone 3GS) but does not in IE8 and FF 3.6.

To reproduce - use attached file. To workaround I used the callback to set this.focus(). For iPhone this.focus() did not solve the issue - this.select() did.

Attachments (1)

1.htm (455 bytes) - added by nahmias.dror 10 years ago.
reproduction of bug

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by nahmias.dror

Attachment: 1.htm added

reproduction of bug

comment:1 Changed 9 years ago by snover

Milestone: 1.4.3

Resetting milestone to future.

comment:2 Changed 9 years ago by snover

Priority: undecided
Resolution: wontfix
Status: newclosed

Thanks for the report, but this is not something we can solve. Since $.animate is unaware of the context in which it is executing, you will need to perform any workarounds yourself if you call it in a focus handler.

Note: See TracTickets for help on using tickets.