Bug Tracker

Opened 7 years ago

Closed 6 years ago

Last modified 5 years ago

#6281 closed enhancement (worksforme)

Slots for animations

Reported by: AzaToth Owned by:
Priority: low Milestone: 1.6
Component: effects Version: 1.4.2
Keywords: Cc:
Blocked by: Blocking:

Description

This patch adds slots to the fx mechanism and results in that all animations in a given slot will use the same time quanta.

Attachments (3)

jquery.fx.slot.patch (4.3 KB) - added by AzaToth 7 years ago.
0001-Animation-slots.patch (5.4 KB) - added by AzaToth 7 years ago.
updated patch to clean up the interface
0001-Animation-slots.2.patch (5.8 KB) - added by AzaToth 7 years ago.
updated patch to remove the requirement to call reset on chained animations

Download all attachments as: .zip

Change History (14)

Changed 7 years ago by AzaToth

Attachment: jquery.fx.slot.patch added

Changed 7 years ago by AzaToth

Attachment: 0001-Animation-slots.patch added

updated patch to clean up the interface

comment:1 Changed 7 years ago by AzaToth

A more detailed reason for this:

When multiple animations are meant to be executed in "parallel", currently they will be asynchronous and thus experience an delayed animation for later elements. To overcome this issue, we add an slot mechanism which specifies that we can use one single slot for a bunch of animations, and they all will use the same start time and current time.

comment:2 Changed 7 years ago by AzaToth

Here is a visual test; the "normal" is what current behavior is, and slotted is when the effect uses the same slot:

http://js.azatoth.net/test/slotted.html

Changed 7 years ago by AzaToth

updated patch to remove the requirement to call reset on chained animations

comment:3 Changed 7 years ago by AzaToth

See http://js.azatoth.net/test/slotted2.html for example using second patch.

comment:4 Changed 7 years ago by snover

Milestone: 1.4.3

Resetting milestone to future.

comment:5 Changed 7 years ago by snover

Priority: low
Status: newopen

comment:6 Changed 7 years ago by dmethvin

Milestone: 1.5

comment:7 Changed 7 years ago by dmethvin

#7490 is a duplicate of this ticket.

comment:8 Changed 7 years ago by grevian+jquery@…

Would it be possible to have a callback added for when all elements in a particular slot have finished execution? Also I find the terminology of "slot" to be a little odd, wouldn't "set" or "group", possibly prefixed like "fxgroup" or "AnimationSet" be more appropriate?

comment:9 Changed 7 years ago by gnarf

Another approach to synchronizing animations - http://bugs.jquery.com/ticket/7917 - I opened it having not found this ticket while searching.

comment:10 Changed 6 years ago by AzaToth

comment:11 Changed 6 years ago by john

Milestone: 1.6
Resolution: worksforme
Status: openclosed

This was fixed with the resolution of #7917.

Note: See TracTickets for help on using tickets.