Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#6280 closed bug (worksforme)

IE8 : Non valid argument at line 4618

Reported by: christian Owned by:
Priority: Milestone: 1.4.2
Component: unfiled Version: 1.4.2
Keywords: Cc:
Blocked by: Blocking:

Description

Both in the minified 1.4.2 or in the dev release I got this error with IE8 (XP SP3)

Invalid argument (at line 4618 for the dev version)

Change History (4)

comment:1 Changed 10 years ago by smdavidson

I modified line 4586 to fix this one...

old:

if ( (name === "width"
name === "height") && parseFloat(value) < 0) {

new:

if ( (name === "width"
name === "height") && (parseFloat(value) < 0 parseFloat(value) + "" === "NaN")) {

comment:2 Changed 10 years ago by smdavidson

Addendum to the previous post...there should be an 'OR' operator between parseFloat(value) < 0 and parseFloat(value + "" === "NaN". I think the text editor removed the pipes.

comment:3 Changed 10 years ago by dmethvin

Resolution: worksforme
Status: newclosed

It sounds like you may be passing invalid arguments to jQuery. Please provide a simple test case that shows how the problem occurs.

comment:4 Changed 9 years ago by psd-dude.com

Hi,

might I suggest adding to line 4586 the following

old:
if ( (name === "width" || name === "height")

new:

if ( (name === "width" || name === "height" || name === "marginLeft" || name === "marginRight" || name === "marginTop" || name === "marginBottom")

I bumped into the error signaled and your fix did not work for me in IE8. I was using the jqueryUI .tabs and the error was caused by the attempt to set "marginLeft" with "NaNpx"

hope this helps kindest regards John

Note: See TracTickets for help on using tickets.