Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#6270 closed bug (worksforme)

On Firefox 3.6, $(document).ready(...) doesn't get triggered after a back button

Reported by: tomasix Owned by:
Priority: low Milestone: 1.4.2
Component: event Version: 1.4.2
Keywords: document ready, firefox, back-button Cc:
Blocked by: Blocking:

Description

On Firefox 3.6, $(document).ready(...) doesn't get triggered when the page that contains the above code shows as a result of the user pushing the back-button.

Change History (5)

comment:1 Changed 9 years ago by addyosmani

Keywords: document back-button added
Priority: low
Resolution: worksforme
Status: newclosed

Using FF3.6 I've recreated your test here as follows:

First navigate to: http://jsfiddle.net/addyosmani/BBWuP/ (uses $(document).ready()) Next navigate to: http://jsfiddle.net/addyosmani/aUrkD/ Back button results in: http://jsfiddle.net/addyosmani/BBWuP/ correctly executing.

Here I was able to execute the code inside the original page's document ready even when I used the back-button to get to the page.

Closing as this works for me, but please feel free to submit a new ticket if this bug reappears.

comment:2 Changed 9 years ago by anonymous

this is NOT resolved.

comment:3 in reply to:  2 ; Changed 9 years ago by anonymous

Replying to anonymous:

this is NOT resolved.

What exact version of FF are you using? Does it have Firebug installed?

comment:4 in reply to:  3 Changed 9 years ago by tomasix

Replying to anonymous:

Replying to anonymous:

this is NOT resolved.

What exact version of FF are you using? Does it have Firebug installed?

I'm using FF 3.6.12 WITH Firebug, and with a local test.html I can confirm that the bug IS ALREADY THERE. Although, using jsFiddle bug doesn't manifest.

Should I suggest not to use jsFiddle for this one?

Bug should be reopened.

comment:5 Changed 9 years ago by ajpiano

I was able to dupe this bug in FF 3.6.13 and jQuery 1.4.4... however, when I tested against the latest GIT, it worked fine.

You can use http://jsfiddle.net/BBWuP/4/show (which is an update of addyosmani's fiddle to use 1.4.4) and it should fail

http://jsfiddle.net/BBWuP/5/show (GIT 0) seems to work...

Note: See TracTickets for help on using tickets.