Bug Tracker

Opened 10 years ago

Closed 10 years ago

#6269 closed bug (duplicate)

Plain Object Event Unbind throws exception when unbinding last handler for given event.

Reported by: khoipham Owned by:
Priority: Milestone: 1.4.3
Component: event Version: 1.4.2
Keywords: event unbind Cc:
Blocked by: Blocking:

Description

When unbinding an event attached to a plain object, an exception is thrown when trying to remove generic event handler when if no more handlers exist.

Line 1772 calls >>

removeEvent( elem, type, elemData.handle );

removeEvent expects a DOM element, but plain object is passed instead.

Attachments (1)

qunit2.html (1.9 KB) - added by khoipham 10 years ago.
QUnit test

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by khoipham

Attachment: qunit2.html added

QUnit test

comment:1 Changed 10 years ago by john

Component: unfiledevent
Resolution: duplicate
Status: newclosed

Duplicate of #6184.

Note: See TracTickets for help on using tickets.