Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#6249 closed bug (duplicate)

IE6 does not support the change event of "select" element while using live

Reported by: yechenhui Owned by:
Priority: undecided Milestone: 1.4.3
Component: event Version: 1.4.2
Keywords: Cc:
Blocked by: Blocking:

Description

The change and submit events work reliably across browsers for both normal and live events. We override the normal change and submit events in Internet Explorer and replace them with events that work identically to the other browsers.

---

This is true for IE8 & FireFox, but not for IE6. It seems to ignore live bound change events.

Change History (3)

comment:1 Changed 10 years ago by Psyclo

This is also true for IE7. It ignores the .live('change') event for select elements.

comment:2 Changed 10 years ago by ain

I can confirm this on IE7 and not only in regard to select elements but on radio controls as well, e.g.

$("input[name='radioInputName']").live("change", handlerFunction);

isn't working either.

comment:3 Changed 9 years ago by john

Priority: undecided
Resolution: duplicate
Status: newclosed

I think this is a duplicate of #6505 - kind of hard to determine considering this ticket is lacking additional information and test cases.

Note: See TracTickets for help on using tickets.