Bug Tracker

Opened 10 years ago

Closed 10 years ago

#6245 closed bug (duplicate)

JavaScript error on unload

Reported by: erikkallen Owned by:
Priority: Milestone: 1.4.3
Component: event Version: 1.4.2
Keywords: Cc:
Blocked by: Blocking:

Description

I get an error when unloading one of my pages (reproducible for that page, but not for all pages) "undefined is null or not an object". The error occurs inside handle(), line 1903 in jquery-1.4.2.js.

Around there it says:

var events = jQuery.data(this, "events"), handlers = events[event.type];

if (events && handlers) {

...

The problem is that the events variable becomes undefined, which was supposed to be taken care of by the if statement, but it blows already when assigning handlers.

Change History (2)

comment:1 Changed 10 years ago by erikkallen

For reference, in jquery-1.3.2, the same statement says

handlers = ( jQuery.data(this, "events")
{} )[event.type];

comment:2 Changed 10 years ago by john

Component: coreevent
Resolution: duplicate
Status: newclosed

Duplicate of #6163.

Note: See TracTickets for help on using tickets.