Bug Tracker

Opened 10 years ago

Closed 10 years ago

#6228 closed bug (invalid)

jquery seem to conflict with object.prototype.create

Reported by: bobvanhoove Owned by:
Priority: Milestone: 1.4.3
Component: unfiled Version: 1.4.2
Keywords: Cc:
Blocked by: Blocking:

Description

When i put the following code in my script

if ( ! Object.prototype.create ) {

Object.prototype.create = function (o) {

var F = function () {};

F.prototype = o; return new F();

};

}

along with jQuery I get load errors in the following lines:

Object doesn't support this property or method jquery-1.4.2.js, line 2828 character 4

Change History (2)

comment:1 Changed 10 years ago by bobvanhoove

Ah, i found the cause sorry for bothering:

http://ejohn.org/blog/ecmascript-5-objects-and-properties/

comment:2 Changed 10 years ago by john

Resolution: invalid
Status: newclosed

Yep, jQuery doesn't attempt to work with Object.prototype manipulation.

Note: See TracTickets for help on using tickets.