Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6214 closed bug (duplicate)

1.4.2 AJAX .abort script error in IE

Reported by: itbeyond Owned by:
Priority: Milestone: 1.4.3
Component: ajax Version: 1.4.2
Keywords: abort Cc:
Blocked by: Blocking:

Description

Request .abort() in IE seems to throw a script error which it did not do in 1.3.2. The code below:

var p5k_aid = null; $jq(document).ready(function() { $jq('#p5k_pib_b_dl a').mouseover(function() { if (p5k_aid) {p5k_aid.abort()} p5k_aid = $jq.get(BaseURL + '/Utilities/Ajax/getKeyword.aspx?id=W' + $jq(this).attr('id').replace('p5k_', ), function(html) { $jq('#p5k').html(html);}); }).first().mouseover(); });

Works perfectly in Firefox (firebug shows the abort) but in IE throws a script error: Object doesn't support this property or method - Line: 170 - Char: 489. Coupled with this the abort itself does not trigger so the ajax command processes to the end (in my case can cause out of sequence responses)

I have just started using 1.4.2 and this is the first little issue I have found. Any help or ideas.

Change History (3)

comment:1 Changed 10 years ago by itbeyond

Sorry I posted this before I found the other issues I believe it is a duplicate however it is still occurring.

comment:2 Changed 10 years ago by john

Resolution: duplicate
Status: newclosed

comment:3 Changed 10 years ago by john

Duplicate of #6037.

Note: See TracTickets for help on using tickets.