Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#6127 closed bug (duplicate)

Calling .abort() on AJAX Request Triggers "success" callback

Reported by: jarcoal Owned by:
Priority: low Milestone: 1.4.2
Component: ajax Version: 1.4
Keywords: ajax abort Cc:
Blocked by: Blocking:

Description

From 1.4+ calling abort on an AJAX request still fires the callback and the status identifies it as a "success." This is not the same functionality as 1.3.2, which would keep the callback from firing.

Change History (3)

comment:1 Changed 10 years ago by dlee

I can confirm this behavior on IE7, and http://forum.jquery.com/topic/after-aborting-an-ajax-call-success-event-is-still-being-fired mentions the same problem.

comment:2 Changed 9 years ago by addyosmani

Priority: low
Resolution: duplicate
Status: newclosed

This has been fixed already here http://github.com/jquery/jquery/commit/ba9e0fc177841bd74cc5ea4e52f09cd87d747bf5 but it's a duplicate of #6060

comment:3 Changed 9 years ago by addyosmani

Duplicate of #6060.

Note: See TracTickets for help on using tickets.