Bug Tracker

Opened 9 years ago

Closed 8 years ago

#6116 closed bug (invalid)

FF error on: var computedStyle = defaultView.getComputedStyle( elem, null );

Reported by: spinemelter Owned by: spinemelter
Priority: undecided Milestone:
Component: css Version: 1.4.1
Keywords: firefox getcomputedstyle Cc:
Blocked by: Blocking:

Description

In Firefox 3.5 (Mac) I get the below error, but not in Safari (Mac).

Fel: uncaught exception: [Exception... "Could not convert JavaScript argument arg 0" nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)" location: "JS frame :: http://localhost:8080/ma3-gibbon/incs/js/jquery-1.4.1.js :: anonymous :: line 4535" data: no]

Change History (8)

comment:1 Changed 9 years ago by john

Component: unfiledcss
Resolution: invalid
Status: newclosed

Unfortunately I can't really do much without a test case - can you spot what triggered this particular error?

Please re-open the ticket if you do.

comment:2 Changed 9 years ago by spinemelter

Resolution: invalid
Status: closedreopened

Ouch.. sorry! I totally forgot the example that I have.

http://manalyze.se/gibbon

klick the first "text-button" in the carousel in the bottom left corner (it says TrnComp_line). In Safari and Google Chrome it opens a table in the center pane, but FF 3.5.8 opens the table in a new window and in the Error console in FF I get the above error.

I run a Mac if that has anything to do with it.

Other info, don't know if that helps or anything... The same plugin (ajaxify) that is used to open the text-button link in the center pane, is used in the "gear menu" (white and orange circle in the top left corner of the center pane). If you go into "Preferences" and then "Rearrage Favourites", it loads that page in the center pane. Actually it prints an error, I just saw, but it does that in the center pane... so, here it works in all browsers I've tried.

comment:3 Changed 9 years ago by spinemelter

Just tried it with jquery 1.3.2, and it worked, but not 1.4 and not 1.4.1.

comment:4 Changed 9 years ago by spinemelter

Bump?

comment:5 Changed 9 years ago by spinemelter

Same error with jQuery 1.4.2. Works on Safari and Chrome, but not Firefox.

comment:6 Changed 9 years ago by pakronenberg@…

I believe I am getting this same error with jquery 1.4.3. Trying to set the offset of an element in Firefox. Is there any update?

comment:7 Changed 9 years ago by snover

Owner: set to spinemelter
Priority: undecided
Status: reopenedpending

Could you please provide a reduced test case on jsFiddle? Thanks!

comment:8 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Automatically closed due to 14 days of inactivity.

Note: See TracTickets for help on using tickets.