Bug Tracker

Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#6106 closed bug (fixed)

Data argument is undefined in success method of $.ajax in IE7

Reported by: ppickard Owned by: jaubourg
Priority: high Milestone: 1.5
Component: ajax Version: 1.4
Keywords: json, ajaxrewrite Cc:
Blocked by: Blocking:


When using dataType:"json" in a .ajax method, the data object is undefined in ie6/ie7. It works fine in ie8/ff.

I was able to get to the data through the XMLHttpRequest argument, just not directly through the data argument.

Change History (6)

comment:1 Changed 5 years ago by addyosmani

#5156 is a duplicate of this ticket.

comment:2 Changed 5 years ago by SlexAxton

  • Milestone changed from 1.4 to 1.5
  • Priority set to high
  • Status changed from new to open

Verified to be true.

#5156 has a bit more insight and was first, but we can just keep it clean.

comment:3 Changed 5 years ago by rwaldron

  • Owner set to jaubourg
  • Status changed from open to assigned

This needs to be reverified with the new ajax module.

comment:4 Changed 5 years ago by ajpiano

  • Keywords ajaxrewrite added

comment:5 Changed 5 years ago by rwaldron

  • Keywords changed from json ajaxrewrite to json,ajaxrewrite

comment:6 Changed 5 years ago by jaubourg

  • Resolution set to fixed
  • Status changed from assigned to closed

Ajax now uses parseJSON internally which actually returns null for non-string and empty values. So it's safe to say this is fixed (I had to look into #5156 to understand the issue so I invite readers to go there if they're as lost as I was).

Note: See TracTickets for help on using tickets.