Bug Tracker

Opened 10 years ago

Closed 10 years ago

#6087 closed bug (invalid)

Firefox 3.5.7 iframe length incorrect

Reported by: subt13 Owned by:
Priority: Milestone:
Component: core Version: 1.4
Keywords: iframe length count Cc:
Blocked by: Blocking:

Description

issuing this command in firefox 3.5.7: alert( $( 'iframe' ).length ) returns a different length than the exact same code in ie 7/8. here is mark I used to reproduce:

<html> <head>

<script src="jquery-1.3.2.min.js" type="text/javascript"></script> <script type="text/javascript">

$(function() {

alert($('iframe').length);

});

</script>

</head> <body>

<div>

<iframe src="" />

</div> <div style="">

<iframe src="" />

</div> <div style="display:none">

<iframe src="" />

</div> <div style="display:none">

<iframe src="" />

</div>

</body> </html>

Change History (2)

comment:1 Changed 10 years ago by subt13

I noticed when I closed the iframes with </iframe> jQuery found them. Perhaps it was just bad markup and not a bug

comment:2 Changed 10 years ago by john

Resolution: invalid
Status: newclosed

Correct, self-closing iframes are malformed markup.

Note: See TracTickets for help on using tickets.