Bug Tracker

Opened 10 years ago

Closed 10 years ago

#6080 closed bug (invalid)

problem updating div content inside a dialog box

Reported by: jdgamble555 Owned by:
Priority: Milestone: 1.4.2
Component: data Version: 1.4.1
Keywords: div, content, dialog, box, value Cc:
Blocked by: Blocking:

Description

I have a div inside my dialog box like so:

<div id="dialog_box"> stuff... <div id="changethisdiv">not changed</div> </div>

And I would like to be able to update the "changethisdiv" more than ONCE. However, it will only update on the first call to open the dialog:

function open_dialog() {

$("#dialog_box").dialog('destroy'); $("#dialog_box").dialog({

buttons: {

'Edit Thumb': function() {

$("#myThumbForm").submit();

}, Cancel: function() {

$(this).dialog('close');

}

}, close: function() { }, open: function() {

$("#changethisdiv").html("it is changed at" + new Date().getTime());

}

});

$("#dialog_box").dialog('open'); return false;

}

If I take this:

<div id="changethisdiv">not changed</div>

out of the dialog box, it is updated everytime...

Change History (2)

comment:1 in reply to:  description Changed 10 years ago by jdgamble555

You can delete this post, it is not a bug and works fine, I will place my other problem related to this in a new ticket!

comment:2 Changed 10 years ago by john

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.