Bug Tracker

Opened 10 years ago

Closed 10 years ago

#6067 closed bug (wontfix)

.change() event handler is not fired when using keyboard to change selection in a <select>

Reported by: KennethRMason Owned by:
Priority: Milestone: 1.4.2
Component: event Version: 1.4.1
Keywords: select change keyboard Cc: kmason@…
Blocked by: Blocking:

Description

The .change() event will reliably fire when using the mouse to select a value from a <select> element. However, once giving focus to the select, if the keyboard is used to change the value of the select, the .change() event handler is not called. Since the value has changed (regardless of the input method), the .change() handler should be called.

Consider as example:

<select id="#selectID">

<option value="1">A</option> <option value="2">B</option>

</select> <script>

$("selectID").change(function(){ alert("Alert"); });

</script>

In this example, as long as the mouse is used to make a selection, the alert occurs. If the keyboard is used, the alert does not occur.

Consistently reproducible on Firefox 3.5.7.

Change History (1)

comment:1 Changed 10 years ago by john

Resolution: wontfix
Status: newclosed
Version: 1.2.61.4.1

The change will fire once you navigate away from the select. This is consistent across all browsers and is expected.

Note: See TracTickets for help on using tickets.