Bug Tracker

Opened 10 years ago

Closed 10 years ago

#6066 closed bug (duplicate)

Bound change event not triggered until element loses focus a second time

Reported by: mweeda Owned by:
Priority: Milestone: 1.4.2
Component: event Version: 1.4.1
Keywords: onchange IE bind Cc:
Blocked by: Blocking:

Description

This behavior appears when upgrading from jQuery 1.3.2 to 1.4.1. It appears under IE 8.0.6001.18882 but not under Firefox 3.5.7.

A function bound with: jQuery("#"+fieldName).bind('change', {...}, jQuery("#"+fieldName).RSV.fieldValidate); is triggered only when an element is changed and loses focus for the second (or subsequent) time. That is, if the element gains focus for the first time, its value is changed, and then loses focus, the function isn't triggered. On the other hand if the element gains focus, loses focus, gains focus again, the value is changed, and then loses focus, the function is triggered.

Change History (1)

comment:1 Changed 10 years ago by john

Resolution: duplicate
Status: newclosed

Duplicate of #5851 (already fixed).

Note: See TracTickets for help on using tickets.