Bug Tracker

Opened 10 years ago

Closed 9 years ago

#6036 closed bug (duplicate)

Animating visibility breaks the display type of elements.

Reported by: lhunath Owned by:
Priority: major Milestone: 1.4.2
Component: effects Version: 1.4.1
Keywords: Cc:
Blocked by: Blocking:

Description

While .toggle(); correctly preserves the element's display type, animate(height: 'toggle'); for instance, does not.

In fact, in 1.4 it seems to be that the display type is first set to "block" for the duration of the animation and then reset to the correct display type.

See test case at: http://stuff.lhunath.com/jquery-tbody-block.html

This breaks the layout of my tables as block obviously renders differently than table-row-group.

Change History (3)

comment:1 Changed 10 years ago by marcandre

+1

Completely unusable for table rows spanning more than a row, for instance.

See my test case at: http://marc-andre.ca/posts/misc/jQuery_row_bug.html

comment:2 Changed 9 years ago by dmethvin

Component: unfiledfx

comment:3 Changed 9 years ago by snover

Resolution: duplicate
Status: newclosed

Duplicate of #2185.

Note: See TracTickets for help on using tickets.