Bug Tracker

Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#6004 closed bug (duplicate)

Attribute equals selector doesn't work in IE8 with empty value attribute

Reported by: altman Owned by:
Priority: high Milestone: 1.next
Component: selector Version: 1.4.3
Keywords: Attribute Equals Selector, IE8 Cc:
Blocked by: Blocking:

Description

The attribute Equals Selector for value = "" does not work in IE8. This works if you change IE8 to IE7 Standards mode. It only happens if you are trying to select inputs with value of blank. If the value is not blank, then it works. See Attachment

Attachments (1)

test.html (703 bytes) - added by altman 9 years ago.
Test HTML Showing Attribute Selector Bug

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by altman

Attachment: test.html added

Test HTML Showing Attribute Selector Bug

comment:1 Changed 9 years ago by dmethvin

Component: unfiledselector

comment:2 Changed 8 years ago by snover

Milestone: 1.4.21.4.5
Priority: majorhigh
Status: newopen
Version: 1.4.11.4.3

This appears to be a bug in IE8’s implementation of querySelectorAll. Neat!

comment:3 Changed 8 years ago by snover

Summary: Attribute Equals Selector Doesn't work in IE8Attribute equals selector doesn't work in IE8 with empty value attribute

comment:4 Changed 8 years ago by snover

comment:5 Changed 8 years ago by dmethvin

Triage confirmed.

comment:6 Changed 8 years ago by john

Resolution: duplicate
Status: openclosed

comment:7 Changed 8 years ago by john

Duplicate of #5637.

Note: See TracTickets for help on using tickets.