Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5998 closed bug (duplicate)

Cloning a form in IE will break up <form>-tags

Reported by: Javache Owned by: john
Priority: low Milestone:
Component: manipulation Version: 1.4.1
Keywords: Cc:
Blocked by: Blocking:

Description

When the action ends with a '/', IE will split the <form>-tags and thus break the form.

For more information see: http://forum.jquery.com/topic/ie-bug-cloning-a-form A testcase can be found at http://thinkjavache.be/jQuery/test-deep-clone.html

Change History (8)

comment:1 Changed 9 years ago by john

Milestone: 1.4.2
Owner: set to john
Priority: minormajor
Status: newassigned

Your demo was only using .submit() instead of .live("submit"). I fixed it but still see the problem. I'll check into it more.

comment:2 Changed 9 years ago by john

Resolution: fixed
Status: assignedclosed

comment:3 Changed 9 years ago by john

Component: coremanipulation

comment:4 Changed 9 years ago by dmethvin

Milestone: 1.4.21.4.3
Priority: majorlow
Resolution: fixed
Status: closedreopened

Failing test case for 1.4.2 from duplicate 7072:

http://jsfiddle.net/ZmJWD/3/

comment:5 Changed 9 years ago by leoshklo

It looks like 1.4.3 has shipped without addressing this bug, what's the process for getting it into 1.4.4 or 1.4.5?

comment:6 Changed 9 years ago by snover

Milestone: 1.4.3

Resetting milestone to future.

comment:7 Changed 9 years ago by snover

Resolution: duplicate
Status: reopenedclosed

comment:8 Changed 9 years ago by snover

Duplicate of #6236.

Note: See TracTickets for help on using tickets.