Bug Tracker

Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#5994 closed bug (duplicate)

prevAll and parents return in reverse document order

Reported by: john Owned by:
Priority: high Milestone: 1.5
Component: core Version: 1.4
Keywords: Cc:
Blocked by: Blocking:

Description

The return order should be brought inline with the all the other jQuery methods.

http://forum.jquery.com/topic/revert-to-old-fn-add-behaviour-but-provide-a-fn-sort

Change History (5)

comment:1 Changed 9 years ago by Zero Grav

The order seems to differ when using Internet Explorer 7. IE7 uses eq(0) to locate the object the furthest away while other browsers show the object the nearest to your original object.

comment:2 Changed 9 years ago by snover

Milestone: 1.4.41.5
Priority: majorhigh
Status: newopen

comment:3 Changed 9 years ago by dmethvin

We've documented that "the elements are returned in order from the closest parent to the outer ones" so making this change could break a lot of code.

Since other operations may re-sort the collection we can't guarantee that the reversed order is preserved on a chain.

comment:4 Changed 8 years ago by jitter

Resolution: duplicate
Status: openclosed
Version: 1.4.11.4

You said it yourself. Wontfix.

comment:5 Changed 8 years ago by jitter

Duplicate of #6178.

Note: See TracTickets for help on using tickets.