Skip to main content

Bug Tracker

Side navigation

#5966 closed bug (fixed)

Opened January 28, 2010 02:49PM UTC

Closed October 20, 2010 03:31AM UTC

getJSON callback does not fire

Reported by: ivston Owned by:
Priority: critical Milestone: 1.4.2
Component: ajax Version: 1.4.1
Keywords: getjson callback fire Cc:
Blocked by: Blocking:

with JQ 1.4.1, the following getJSON request to a CodeIgniter-based PHP-application is executed correctly and data is passed back ok (checked with Firebug) but the callback does not fire. The same request with JQ 1.3.2 works fine.

function button_pressed(){


$.getJSON('+this.value, function(data){ alert('OK');});

return false;


Attachments (0)
Change History (5)

Changed January 28, 2010 03:08PM UTC by ivston comment:1

pp. I just tried with the nightly version (v1.4a2pre) and the problem there seems to be solved.

Changed January 29, 2010 02:37AM UTC by dmethvin comment:2

resolution: → fixed
status: newclosed

Fixed...somehow. :)

Changed April 05, 2010 03:03PM UTC by patate comment:3

resolution: fixed
status: closedreopened

I just tried the nightly and have been able to reproduce the issue

Seems 1.4.2 and 1.4.3pre (nightly) are affected

If I rollback to 1.3.2 everything is fine.

Personally i would consider this a serious bug given that it's present on 1.4.2 and given :

jquery getjson callback does not fire

so much for an automagic fix ;)

Changed April 08, 2010 12:35AM UTC by patate comment:4

yeah ends up my json was invalid, i feel stupid


Changed October 20, 2010 03:31AM UTC by addyosmani comment:5

keywords: → getjson callback fire
resolution: → fixed
status: reopenedclosed

Closing as fixed as the first comment in the thread comfirms. dmethvin and patate also (eventually in this case) confirm that this is now fixed.