Bug Tracker

Opened 10 years ago

Closed 9 years ago

#5966 closed bug (fixed)

getJSON callback does not fire

Reported by: ivston Owned by:
Priority: critical Milestone: 1.4.2
Component: ajax Version: 1.4.1
Keywords: getjson callback fire Cc:
Blocked by: Blocking:

Description

with JQ 1.4.1, the following getJSON request to a CodeIgniter-based PHP-application is executed correctly and data is passed back ok (checked with Firebug) but the callback does not fire. The same request with JQ 1.3.2 works fine.

function button_pressed(){

allert(this.value);

$.getJSON(http://xxx.xxx.xxx.xxx/CodeIgniter/index.php//my_controller/my_function/'+this.value, function(data){ alert('OK');});

return false;

}

Change History (5)

comment:1 Changed 10 years ago by ivston

pp. I just tried with the nightly version (v1.4a2pre) and the problem there seems to be solved.

comment:2 Changed 10 years ago by dmethvin

Resolution: fixed
Status: newclosed

Fixed...somehow. :)

comment:3 Changed 10 years ago by patate

Resolution: fixed
Status: closedreopened

I just tried the nightly and have been able to reproduce the issue

Seems 1.4.2 and 1.4.3pre (nightly) are affected

If I rollback to 1.3.2 everything is fine.

Personally i would consider this a serious bug given that it's present on 1.4.2 and given : jquery getjson callback does not fire

so much for an automagic fix ;)

comment:4 Changed 10 years ago by patate

yeah ends up my json was invalid, i feel stupid

sorry!!

comment:5 Changed 9 years ago by addyosmani

Keywords: getjson callback fire added
Resolution: fixed
Status: reopenedclosed

Closing as fixed as the first comment in the thread comfirms. dmethvin and patate also (eventually in this case) confirm that this is now fixed.

Note: See TracTickets for help on using tickets.