Bug Tracker

Opened 9 years ago

Closed 8 years ago

Last modified 7 years ago

#5957 closed bug (invalid)

Error on Sizzle.selectors.filter.PSEUDO

Reported by: mmchida Owned by: mmchida
Priority: major Milestone: 1.4.2
Component: selector Version: 1.4.1
Keywords: Cc:
Blocked by: Blocking:

Description

I have an application that works perfectly with jquery-1.3.2. While I tested the new version of jquery-1.4.1, I have an error in line 3106 (Sizzle.error( "Syntax error, unrecognized expression: " + name )). I debug the application in Chrome and see that the parameter "match" of "PSEUDO" function is an array of [select, select, undefined, undefine]. So, the local variable "name" has a value "select" and the local variable "filter" has a value "undefined", throwing the Sizzle.error. I'm new in Javascript, so I can be wrong, but I think the cause of this error is the function Expr.filters[name], that evals the local variable "name" and don´t have a filter for "select" element. Sorry for my bad english too.

Change History (3)

comment:1 Changed 9 years ago by mmchida

In line 3045 is necessary to add the function:

select: function(elem) {

return "select" === elem.nodeName.toLowerCase();

}

Textareas maybe wrong too.

comment:2 Changed 9 years ago by snover

Owner: changed from john to mmchida
Status: newpending

Please provide a working, minimal test case demonstrating this issue.

comment:3 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.