Bug Tracker

Opened 10 years ago

Closed 9 years ago

#5941 closed bug (invalid)

is() function bug

Reported by: ultimas Owned by:
Priority: major Milestone: 1.4.2
Component: unfiled Version: 1.4.1
Keywords: Cc:
Blocked by: Blocking:

Description

I have the following situation:

$('.btn,.btn-bullet',oContexto
document)

.filter('.btn') .before(function(){

return '<div class="btn-wrapper"'+($(this).is(':visible')?:' style="display:none"')+'><img src="'+BASE_URL+'public/img/btn_esq.gif" alt="" /></div>';

})

when the is() is executed I get this error:

elem.ownerDocument is null at Line 4529.

I'm on FF and it happens since the version 1.4

Btw, the problem that I related here #5908 persists

Attachments (2)

testcase.html (248 bytes) - added by ultimas 10 years ago.
testcase V2.html (1.0 KB) - added by ultimas 10 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 years ago by neerajdotname

looks like formatting got mangled. Can you repost your html and jQuery code so that I could recreate the error.

Thanks

comment:2 Changed 10 years ago by ultimas

I'm sorry but I can't reproduce this error anymore, I may have missed something on the first time. At least, I'll add the #5908 testcase.

Changed 10 years ago by ultimas

Attachment: testcase.html added

Changed 10 years ago by ultimas

Attachment: testcase V2.html added

comment:3 Changed 10 years ago by ultimas

Ok, got the 2 errors...

comment:4 Changed 9 years ago by dmethvin

Resolution: invalid
Status: newclosed

$(true) isn't a valid way to construct a jQuery object.

Note: See TracTickets for help on using tickets.