Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#5918 closed bug (duplicate)

:not filter bug for input of type BUTTON on IE

Reported by: NadAf Owned by: NadAf
Priority: major Milestone: 1.4
Component: selector Version: 1.4
Keywords: Cc:
Blocked by: Blocking:

Description

Hi, I am trying to use the following code on IE 8 for an input of type button. It seems that the :NOT filter is not working when combined with attribute.

Match all inputs with ID=comment and not having attached attribute.

$("input#comment:not([attached])").attr("attached", true).click(function() {alert('Can you see me?')});

However, it works fine on FireFox.

Change History (5)

comment:1 Changed 9 years ago by dmethvin

Component: unfiledselector

comment:2 Changed 9 years ago by dmethvin

Owner: set to NadAf
Status: newpending

Please provide a test case. I have a feeling that the problem is related to [attached] and has nothing to do with button.

comment:3 Changed 9 years ago by NadAf

Status: pendingnew

Here is a test case: http://jsfiddle.net/Ln6xU/1/

You should not see the alert box. However, on IE, you see it.

comment:4 Changed 9 years ago by snover

Resolution: duplicate
Status: newclosed

comment:5 Changed 9 years ago by snover

Duplicate of #5930.

Note: See TracTickets for help on using tickets.