Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#5916 closed bug (duplicate)

e.preventDefault doesn't work with live submit

Reported by: rmurphey Owned by: brandon
Priority: major Milestone: 1.4.1
Component: event Version: 1.4
Keywords: Cc:
Blocked by: Blocking:

Description

When a submit handler is bound to a form using .live(), and the submit handler includes e.preventDefault(), the form still submits when the submit event is triggered using .trigger(). When the same submit handler is bound using .bind(), the form is not submitted.

Test case: http://jsbin.com/arepo/3/edit

Change History (3)

comment:1 Changed 10 years ago by paul.irish

this is a dupe of #5695

comment:2 Changed 10 years ago by Rick Waldron

Attempted same test above with:

return false;

in place of e.preventDefault();

And produced same results

comment:3 Changed 10 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Paul's cross-referenced this in #5695 so I'll close it as a dupe.

Note: See TracTickets for help on using tickets.