Skip to main content

Bug Tracker

Side navigation

#5909 closed bug (invalid)

Opened January 23, 2010 01:28AM UTC

Closed October 07, 2010 07:14AM UTC

can't post multiple values as of 1.4 any more

Reported by: stellsmi Owned by:
Priority: major Milestone: 1.4.1
Component: ajax Version: 1.4
Keywords: Cc:
Blocked by: Blocking:

I try to post this,

$.post("test.php", { 'choices[]': ["Jon", "Susan"] });

but in rails, it sees the result as an array of 2 nils

[nil, nil]

I rolled back to 1.3.2, and it worked

Attachments (0)
Change History (2)

Changed May 26, 2010 10:30PM UTC by cageface comment:1

There were some changes in handling of array parameters in jquery 1.4:

Have you tried omitting the [] from the choices parameter, like this?

$.post("test.php", { 'choices': ["Jon", "Susan"] });

Changed October 07, 2010 07:14AM UTC by snover comment:2

resolution: → invalid
status: newclosed

Closing after 4 months with no feedback from the original submitter. Reopen this bug if the problem persists.