Bug Tracker

Opened 10 years ago

Closed 9 years ago

#5902 closed bug (worksforme)

ajaxComplete event problem, -or- ajaxStart problem?

Reported by: subassio Owned by: subassio
Priority: major Milestone: 1.4.1
Component: ajax Version: 1.4
Keywords: ajaxComplete, ajaxStart Cc:
Blocked by: Blocking:

Description

simple test:

<div id="Div0"></div>

<div id="Div1"></div>

<div id="trigger0">Trigger</div>

<div id="trigger1">Trigger1</div>

<script type="text/javascript">

$('#Div0').ajaxStart(function() {

$("#trigger0").text('Triggered0 ajaxStart handler.');

});

$('#Div0').ajaxComplete(function(event, request, settings) {

$("#trigger0").text('Triggered0 ajaxComplete handler.');

});

$('#Div1').ajaxStart(function() {

$("#trigger1").text('Triggered1 ajaxStart handler.');

});

$('#Div1').ajaxComplete(function(event, request, settings) {

$("#trigger1").text('Triggered1 ajaxComplete handler.');

});

$(document).ready(function() {

$('#Div0').load("Handler.ashx");

});

</script>

result:

$(document).ready(function()..

$('#Div0').ajaxStart..

$('#Div1').ajaxStart..

$('#Div0').ajaxComplete...

Finish

not call $('#Div1').ajaxComplete

-or-

wrong call $('#Div1').ajaxStart ??

Change History (2)

comment:1 Changed 9 years ago by dmethvin

Owner: set to subassio
Status: newpending

Please create a test case using jsfiddle, and explain what you think the test case should do.

comment:2 Changed 9 years ago by jitter

Resolution: worksforme
Status: pendingclosed

test case Can't reproduce this problem

Note: See TracTickets for help on using tickets.