Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#5897 closed bug (worksforme)

Error parsing JSON data in Firefox

Reported by: kalle707 Owned by: kalle707
Priority: low Milestone:
Component: ajax Version: 1.3.2
Keywords: Ajax, Json Cc:
Blocked by: Blocking:

Description

IE7 and Firefox3 have different results on parsing JSON from an Ajax request.

$.ajax({

url:'request.php',type:'POST',async:true,dataType:'json', success:function(j) {

here IE has 7 entries (correct)

Firefox has 6 entries (missing the first one)

}

});

This error occurs only on a special JSON string - mostly the function works fine. (String causing the error is attached)

I've tested this string with a simple script an eval() .. there are no difference between IE and Firefox - the diference occurs only in jQuery.

Attachments (1)

json.error.string.txt (3.0 KB) - added by kalle707 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by kalle707

Attachment: json.error.string.txt added

comment:1 Changed 9 years ago by dmethvin

Owner: set to kalle707
Status: newpending

Please provide a complete test case. I agree the json string seems valid but perhaps it is a charset mismatch or other problem.

comment:2 Changed 9 years ago by jitter

Resolution: worksforme
Status: pendingclosed

Tried your test case with Opera 10.63, Chrome, FF 3.6.12 and IE6 on jQuery 1.4.4. Couldn't reproduce your issue.

All browsers get the whole json object in the success callback.

comment:3 Changed 9 years ago by jitter

Priority: majorlow
Note: See TracTickets for help on using tickets.