Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#5892 closed bug (worksforme)

IE change event does not fire on text input after setting value - works in jQuery 1.3.2, fails in 1.4.0

Reported by: Guiswa Owned by: brandon
Priority: minor Milestone: 1.4.2
Component: event Version: 1.4.1
Keywords: change event IE Cc:
Blocked by: Blocking:

Description

Steps to reproduce using the attached test page:

1.Type "abc" in the first text input element.

2.Hit tab or click elsewhere on the page to trigger the change event - you should see an alert.

3.Click the button to set the value of the first text element to "".

4.Type "abc" in the first text input element again.

5.Hit tab or click elsewhere on the page to trigger the change event again.

Expected:

The alert appears for a second time.

Actual:

The alert does not appear.

Notes:

This only occurs in Internet Explorer 6-8 using jQuery 1.4.0. Previous versions of jQuery do not exhibit this behavior.

Attachments (1)

test.html (1.4 KB) - added by Guiswa 10 years ago.

Download all attachments as: .zip

Change History (17)

Changed 10 years ago by Guiswa

Attachment: test.html added

comment:1 Changed 10 years ago by Guiswa

Here is a jsbin link with the above test page:

http://jsbin.com/ovipi

comment:2 Changed 10 years ago by Guiswa

JSbin was giving me errors earlier, so here's an alternate link for the above test page:

http://dl.dropbox.com/u/11686/test.html

comment:3 Changed 10 years ago by reybango

This looks to have been fixed in 1.4.1. Tested it here:

http://jsbin.com/ovipi/2

comment:4 Changed 10 years ago by john

Milestone: 1.4.11.4.2
Resolution: fixed
Status: newclosed
Version: 1.41.4.1

I can't verify the 1.4.1 claim but it does appear to be fixed in the nightlies.

comment:5 Changed 10 years ago by jasmo

Resolution: fixed
Status: closedreopened

This does not work with at least IE8 http://jsbin.com/ovipi/2

In my current project i have input field with change event binded, and it won't trigger it if i click mouse anywhere in document, but only when i press tab.

When it has fired once, it then works by clicking anywhere in a document as it should.

comment:6 Changed 10 years ago by jasmo

Sorry wrong address up there, i meant:

http://jsbin.com/ovipi/3/

comment:7 Changed 10 years ago by john

Resolution: fixed
Status: reopenedclosed

As mentioned before, this was fixed in 1.4.2.

comment:8 Changed 10 years ago by serdartu

Resolution: fixed
Status: closedreopened

In IE 8 in jquery 1.4.2 it is not working not solved.

comment:9 Changed 9 years ago by petertoi

What is the status on this bug? Is there any known workaround to make it work, and have the change event fired after leaving the input box. For the record I can at - that changing the value will make it fire. e.g

Page loaded: TextInput Value = [Empty]

Editing field: Text Value = ABC - leaving the textbox * no event fired

Editing the field again: Text Value = ABCD - leaving the textbox * event firked!

comment:10 Changed 9 years ago by snover

Resolution: worksforme
Status: reopenedclosed

Live test case Works in jQuery 1.4.2. Upgrade!

comment:11 Changed 9 years ago by kemosite

Seems to be broken again in jQuery 1.4.4

comment:12 Changed 9 years ago by snover

Nope, test case works in 1.4.4 too.

comment:13 Changed 9 years ago by kadlecmark@…

Broken again I believe, the click or change events are not firing in IE8 on the second file input selection.

Using jquery-1.5.1.min.js

comment:14 in reply to:  13 Changed 8 years ago by anonymous

Replying to kadlecmark@…:

Broken again I believe, the click or change events are not firing in IE8 on the second file input selection.

Using jquery-1.5.1.min.js

Yes it fails again using jquery-1.5.1.min.js and IE8 and IE9

comment:15 Changed 8 years ago by anonymous

Still not working on 1.7.1....

comment:16 Changed 8 years ago by wilcoxn@…

fails for me in 1.7.1 too in IE8. change event does not fire when called from a textbox - Firefox is fine

Note: See TracTickets for help on using tickets.