Bug Tracker

Opened 10 years ago

Closed 9 years ago

#5886 closed bug (fixed)

ajax abort error

Reported by: lotjuh Owned by:
Priority: undecided Milestone: 1.4
Component: ajax Version: 1.4
Keywords: ajax abort Cc:
Blocked by: Blocking:

Description

When using jquery 1.4 in combination with jquery ui tabs loading it's content trough ajax, I get the following javascript error: setting a property that has only a getter

The error occurs in the following code: jquery-1.4.js (line 4983)

if ( xhr ) {

xhr.readyState = 0;

}

Tested browsers: Firefox 3.5.8pre -> error occurs Opera 10.10 -> no error

Change History (3)

comment:1 Changed 10 years ago by jmcgraw

I can confirm this bug, failure occurs when in process Ajax request is aborted.

Looks like the try/catch block doesn't handle this kind of error in Firefox.

Tested browsers: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

comment:2 Changed 10 years ago by jmcgraw

This looks like a duplicate for http://dev.jquery.com/ticket/5923

comment:3 Changed 9 years ago by addyosmani

Resolution: fixed
Status: newclosed

Having reviewed the details of this ticket, I see that it's a duplicate of #5923 as correctly pointed out by jmcgraw. This issue was fixed in:

http://github.com/jquery/jquery/commit/76236a15062aa82a4841748e9071eb3c9535ef62

so I am closing it as the bug submitted should no longer be presenting itself. Please feel free to re-open if the issue is experienced once again in 1.4.3.

Note: See TracTickets for help on using tickets.