Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#5847 closed bug (duplicate)

Problem with XHTML

Reported by: Cédric Owned by:
Priority: major Milestone:
Component: selector Version: 1.3.2
Keywords: xhtml Cc:
Blocked by: Blocking:

Description

I'm working with jqtouch. It doesn't work with XHTML pages (header.xhtml)

But if I patch jquery (patch.js) it works.

As you can see, elem.getAttribute( name ) is the problem.

What do you think ?

(I've looked at the version 1.4.1pre and there isn't this kind of fix)

Attachments (3)

header.xhtml (205 bytes) - added by Cédric 10 years ago.
patch.js (211 bytes) - added by Cédric 10 years ago.
Example Jquery with XHTML.zip (168.8 KB) - added by Cédric 10 years ago.
Here is a full example of Jquery not working with XHTML (test it on Safari, with an iPhone user agent)

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by Cédric

Attachment: header.xhtml added

Changed 10 years ago by Cédric

Attachment: patch.js added

comment:1 Changed 10 years ago by dmethvin

Resolution: invalid
Status: newclosed

Can you attach a complete test case? It isn't clear from the fragments here what the underling problem is.

comment:2 Changed 10 years ago by Cédric

Resolution: invalid
Status: closedreopened

It seems others got problems with XHTML Eg. : http://dev.jquery.com/ticket/6162

Changed 10 years ago by Cédric

Here is a full example of Jquery not working with XHTML (test it on Safari, with an iPhone user agent)

comment:3 Changed 9 years ago by dmethvin

Component: unfiledselector

comment:4 Changed 9 years ago by snover

Resolution: duplicate
Status: reopenedclosed

comment:5 Changed 9 years ago by snover

Duplicate of #6162.

Note: See TracTickets for help on using tickets.