Skip to main content

Bug Tracker

Side navigation

#5792 closed bug (fixed)

Opened January 13, 2010 08:47AM UTC

Closed October 16, 2010 03:24PM UTC

1.4rc1 [20090113] Ajax not working in FF3 (3.0.17)

Reported by: alec Owned by:
Priority: low Milestone: 1.4
Component: ajax Version: 1.4
Keywords: ajax ff Cc:
Blocked by: Blocking:

Error: setting a property that has only a getter

Row: 4977

The code is: xhr.readyState = 0;

Attachments (0)
Change History (5)

Changed January 15, 2010 10:33AM UTC by jedrzej comment:1

I have same error in Firefox 3.5.4, Ubuntu 8.04, final jQuery 1.4 (Date: Wed Jan 13 15:23:05 2010 -0500) on line 4983.

It occur if I try to abort() XMLHttpRequest which is already done.

It worked in 1.3.2 and I didn't found any incompatibility reported (, so I want to report this as a bug.

Changed January 15, 2010 06:08PM UTC by trey comment:2

yeah, i'll second (or third if you count the original report) that.

XMLHttpRequest's abort() method is throwing the error about setting a property that only has a getter.

Changed January 19, 2010 06:13PM UTC by simonferragne@hotmai comment:3

Same problem here. 1.4

Changed January 27, 2010 08:14AM UTC by alec comment:4

Fixed in 1.4.1, please close this request.

Changed October 16, 2010 03:24PM UTC by addyosmani comment:5

keywords: → ajax ff
priority: undecidedlow
resolution: → fixed
status: newclosed

As the bug related to this ticket has already been successfully fixed in the past I am closing it as there has been no further comments nor need to keep it open.