Bug Tracker

Opened 10 years ago

Closed 10 years ago

#5765 closed bug (duplicate)

programatic .click() of checkbox reports checkbox state inconsistenly to what is reported from a user click

Reported by: travi Owned by:
Priority: critical Milestone: 1.4
Component: unfiled Version: 1.4a2
Keywords: Cc:
Blocked by: Blocking:

Description

with a click handler attached to a checkbox, a user click and and programmatic .click() report opposite .is(':checked') results inside the click handler.

This causes QUnit tests to report failures with code that works when actual users interact with a page. It has also prevented me from using the same click handler for user clicks and programmatic .click()s in some instances.

I have run the attached QUnit test against 1.2.6, the lastest stable, and the nightly to verify this issue exists in all of those versions.

Attachments (1)

index.html (1.2 KB) - added by travi 10 years ago.
QUnit test

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by travi

Attachment: index.html added

QUnit test

comment:1 Changed 10 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #3827.

Note: See TracTickets for help on using tickets.