Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#5758 closed bug (duplicate)

Manipulation in IE7 drops value of radio buttons

Reported by: Pierre Owned by:
Priority: major Milestone: 1.4
Component: manipulation Version: 1.3.2
Keywords: ie7 manipulation move radio checked value lost Cc:
Blocked by: Blocking:

Description

<html>

<head>

<title>Manipulation in IE7 drops value of radio buttons</title>

<script type="text/javascript" src="http://code.jquery.com/jquery-latest.js"></script>

</head>

<body>

<form>

<h1>Manipulation in IE7 drops value of radio buttons</h1>

<p>Instructions : check "female", then click button.</p>

<p>In Firefox, the checked radio is kept -- That's correct.<br />

In IE, the checked radio is lost -- That's the bug.</p>

<button type="button">Click to move both radio buttons down.</button>

<h2>Source</h2>

<div id="source">

<input type="radio" name="sex" value="male" checked="checked" /> Male

<input type="radio" name="sex" value="female" /> Female

</div>

<h2>Target</h2>

<div id="target"> </div>

</form>

<script type="text/javascript">

$(document).ready(function(){

$("button").click(function(){

var source = $("#source");

var target = $("#target");

target.after(source);

/* the same happens also with before, insertAfter, and insertBefore */

});

});

</script>

</body>

</html>

Attachments (1)

ie7_radio.html (1.0 KB) - added by Pierre 10 years ago.
Demo of the bug (open me in IE7)

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by Pierre

Attachment: ie7_radio.html added

Demo of the bug (open me in IE7)

comment:1 Changed 10 years ago by Pierre

Similar to #1095?

comment:2 Changed 10 years ago by dmethvin

Closest open ticket I can find is #3879, most likely it's a similar cause so I'll cross-reference it there.

comment:3 Changed 10 years ago by Pierre

The value of the radio buttons disappear also when performing .wrap() or .unwrap() on their container.

comment:4 Changed 9 years ago by dmethvin

Component: unfiledmanipulation

comment:5 Changed 9 years ago by snover

Resolution: duplicate
Status: newclosed

comment:6 Changed 9 years ago by snover

Duplicate of #3879.

Note: See TracTickets for help on using tickets.