Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#5749 closed enhancement (duplicate)

Regarding curCSS, css, and backgroundPosition plugin within IE (reproducable in 8)

Reported by: tbranyen Owned by:
Priority: minor Milestone: 1.4
Component: core Version: 1.3.2
Keywords: backgroundPosition, background-position, css Cc:
Blocked by: Blocking:

Description

The CSS property backgroundPosition does not exist in the accessible DOM properties within IE 8. This has caused issues whereas a return value of undefined is passed and breaks the backgroundPosition plugin code.

A fix could be to test for undefined after retrieving backgroundPosition, and if undefined concatenate backgroundPositionX and Y to form the correct return value.

I understand shorthand values are not supposed to be available through css, but this does break functionality within an adopted plugin and cross browser support.

Change History (5)

comment:1 Changed 10 years ago by dmethvin

Component: unfilledcore

Which plugin needs the functionality? It would be best to have the plugin work around the issue so it would work with current/older jQuery.

comment:2 Changed 10 years ago by tbranyen

http://dev.jquery.com/changeset/6073 - this plugin relies on it

Is the only objection to implementing this fix to keep css and curCSS consistent to not supporting shorthand versions?

comment:3 Changed 10 years ago by dmethvin

Type: bugenhancement

I don't have any specific objection to a fix, but at the moment there isn't any fix written and it's not a critical issue so it's not likely to be fixed for 1.4. That's why I suggested a workaround.

comment:4 Changed 9 years ago by dmethvin

Resolution: duplicate
Status: newclosed

We haven't encouraged used of shorthand properties.

comment:5 Changed 9 years ago by dmethvin

Duplicate of #4295.

Note: See TracTickets for help on using tickets.