Bug Tracker

Opened 10 years ago

Closed 9 years ago

#5741 closed bug (worksforme)

$(element).html(val) SERIOUS BUG

Reported by: Taturana Owned by:
Priority: undecided Milestone: 1.4
Component: ajax Version: 1.4a2
Keywords: html Cc:
Blocked by: Blocking:

Description

The problem is: when you change successively the html of an element (and the new html content has javascript code), after certain change the javascript code is no longer executed (inside the element). I'll give example in code, just download the attached file and test. Click successively on the button and you'll see the alert won't appear after the second or third click.

Attachments (1)

test.php (438 bytes) - added by Taturana 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by Taturana

Attachment: test.php added

comment:1 Changed 9 years ago by dmethvin

Component: unfiledajax

comment:2 Changed 9 years ago by zjs

The attachment does not use the $(element).html(val) function you refer to in the subject of the ticket. I'm not sure I see a bug in the provided php file; it seems to be behaving as I would expect it to. Could you verify that you've uploaded the correct attachment?

comment:3 Changed 9 years ago by Rick Waldron

Additionally, this is calling "jquery-1.4a2.min.js"

comment:4 Changed 9 years ago by snover

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.