Bug Tracker

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#5700 closed bug (duplicate)

.class:not(:first) does not work as expected in IE8

Reported by: matiasnu Owned by: john
Priority: low Milestone: 1.4
Component: selector Version: 1.3.2
Keywords: css selectors Cc:
Blocked by: Blocking:

Description

$(".elem:not(:first)") will select all divs with class .elem in IE8, but Chrome and Firefox 3.5 will select all except the first div.

$("div.elem:not(:first)") will select all except the first div in IE8, Chrome and Firefox.

Attached testcase.

Attachments (1)

ie8bug.html (1.2 KB) - added by matiasnu 8 years ago.
Testcase

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by matiasnu

Attachment: ie8bug.html added

Testcase

comment:1 Changed 8 years ago by matiasnu

I get the same behavior in IE8 when using jQuery 1.4rc1, but I guess this is more of a sizzle bug?

comment:2 Changed 7 years ago by addyosmani

Keywords: css selectors added
need: ReviewPatch
Priority: majorlow

I've tried your originally submitted test case and it would indeed appear that the selector $(".elem:not(:first)") is not working as expected in IE8.

Live test case here: http://jsfiddle.net/addyosmani/ZndXa/

Flagging for a further review and patch.

comment:3 Changed 7 years ago by snover

Resolution: duplicate
Status: newclosed

comment:4 Changed 7 years ago by snover

Duplicate of #6838.

Note: See TracTickets for help on using tickets.