Bug Tracker

Opened 10 years ago

Closed 10 years ago

#5693 closed bug (duplicate)

recursion error

Reported by: marcucio Owned by:
Priority: major Milestone: 1.4
Component: event Version: 1.4a2
Keywords: Cc:
Blocked by: Blocking:

Description

This works fine in 1.3.1 but in 1.4a2 when I create a dialog and then call:

$("#tabs").tabs({

selected: 0

});

I get the following error (in firebug). Let me know if you want me to try to create a simpler case to recreate. Is jquery-ui-1.7.2 compatable with jquery 1.4? Here is the error:

too much recursion proxy(Object name=fn, Object name=proxy, Object name=thisObject)jquery-1.4a2.js (line 1486) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1807) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (eliding 2906 frames)()(elidi...frames) (line 0) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) (?)(Object name=type, Object name=data, Object name=fn, Object name=thisObject)jquery-1.4a2.js (line 1811) _init(Object name=n)jquery....min.js (line 121) _init()jquery....min.js (line 121) add()jquery....min.js (line 10) each(Object name=object, Object name=callback, Object name=args)jquery-1.4a2.js (line 534) each(Object name=callback, Object name=args)jquery-1.4a2.js (line 232) add(Object name=p)jquery....min.js (line 10) do_pref_dialog()pref_form.js (line 27) javascript:do_pref_dialog()()javasc...ialog() (line 1) [Break on this error] if ( proxy !== undefined && !jQuery.isFunction( proxy ) ) {

Attachments (1)

ready-test.html (476 bytes) - added by zachleat 10 years ago.
too much recursion error.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 years ago by dmethvin

Can you attach your test case? Thanks.

Changed 10 years ago by zachleat

Attachment: ready-test.html added

too much recursion error.

comment:2 Changed 10 years ago by zachleat

Regression between 1.4a2 and 1.4a1 (worked fine in 1.4a1).

comment:3 Changed 10 years ago by zachleat

Woops, sorry guys, this is a duplicate of #5688.

comment:4 Changed 10 years ago by marcucio

yea it looks like #5688, my app works with 1.4a1 not 1.4a2. This could probably be closed

comment:5 Changed 10 years ago by dmethvin

Component: unfiledevent
Resolution: duplicate
Status: newclosed

Dup of #5688.

Note: See TracTickets for help on using tickets.