Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#5680 closed bug (invalid)

RangeError: Maximum call stack size exceeded.

Reported by: MathieuMa Owned by:
Priority: major Milestone: 1.4
Component: unfiled Version: 1.4a1
Keywords: Cc: mathieuma@…
Blocked by: Blocking:

Description

I get the following error when using 1.4a2 with Safari on OSX :

The error occurs at line 1485 : proxy: function( fn, proxy, thisObject ) {

Plugins used on the page : JqueryUI (tabs, datepicker, dialog, core), autocomplete, and some custom code/plugins.

1.4a1 works as expected on Safari.

Change History (10)

comment:1 Changed 10 years ago by dmethvin

Can you narrow this down to a simple test case?

comment:2 Changed 9 years ago by dmethvin

Resolution: invalid
Status: newclosed

Pre-release bug?

comment:3 Changed 8 years ago by donjohn.fmmi@…

I just began getting this same error in Chrome 13.0.782.112 m and the latest jquery on the google repository.

The Chrome inspector is giving this error message:

Uncaught RangeError: Maximum call stack size exceeded jquery.min.js:16

It could be pretty hard to narrow it down to a test case...

comment:4 in reply to:  3 Changed 8 years ago by anonymous

If it helps any the web page involved is http://www.parrocchiasanlino.org/index.php?mod=database, but you need specific user access to view the page...

comment:5 Changed 8 years ago by Andrès Felipe Quintero

It happens to me in the UI's calendar when I write this code:

dates.not(this).datepicker("option", option, date);

Here's the full example:

var dates = $("#date_init, #date_end").datepicker(
	{
		firstDay: 1,
		onSelect: function( selectedDate )
		{
			var option = this.id == "date_init" ? "minDate" : "maxDate",
			instance = $( this ).data( "datepicker" ),
			date = $.datepicker.parseDate(
					instance.settings.dateFormat ||
					$.datepicker._defaults.dateFormat,
					selectedDate, instance.settings );
			dates.not(this).datepicker("option", option, date);
		}
	});

comment:6 Changed 8 years ago by james.crowley@…

Why is this marked as closed? I'm still seeing this issue.

comment:7 Changed 8 years ago by dmethvin

We don't see it, because there was never a test case. Please provide a reduced test case.

comment:8 Changed 8 years ago by anonymous

I have the same problem during an jquery replaceWith of an huge div element with another div of about 10 lines. It can be reproduced, but it seems to be size dependent. That makes it hard to provide a "reduced test case" In my case is the threshold between 5MB and 8MB of HTML size.

comment:9 in reply to:  8 Changed 8 years ago by Kambix

Replying to anonymous:

I have the same problem during an jquery replaceWith of an huge div element with another div of about 10 lines. It can be reproduced, but it seems to be size dependent. That makes it hard to provide a "reduced test case" In my case is the threshold between 5MB and 8MB of HTML size.

I solved my problem by replacing the following statement:

element.replaceWith(val);

into

var parent = element.parent();
parent.empty();
parent.append(val);

element was the huge part of the HTML DOM

comment:10 Changed 8 years ago by dmethvin

In my case is the threshold between 5MB and 8MB of HTML size.

ಠ_ಠ

Note: See TracTickets for help on using tickets.